Cannot open input file 'Release\tvm.lib'


#1

Hello all,
I currently have TVM installed and functioning properly in a linux environment with access to nvidia GPU’s. I’ve recently been given access to a new Windows desktop containing nvida GPUs well as Intel FPGAs so I’m attempting to install TVM again but am not having much luck so any advice would be appreciated. My steps are as follows

  1. Clone TVM with ‘git clone --recursive https://github.com/dmlc/tvm
  2. Create build directory inside of TVM and copy over config.cmake
  3. Enable LLVM (built from source for both windows and linux installation), cuda, openCL, and AOCL inside the config (The installation of these 4 softwares has already been verified correct)
  4. Build with ‘cmake -G “Visual Studio 15 2017 Win64” -DCMAKE_BUILD_TYPE=Release -DCMAKE_CONFIGURATION_TYPES=“Release” …’ which results in
  5. Open .sln file and build in visual studio where i finally encounter this error
    image

Note: I have already installed the python package by adding those lines to my .bashrc and have installed the additional python dependencies
Edit: I know it says cuDNN cannot be found as well but it’s not important (unless its part of the issue) since I will be focusing exclusively on the FPGA functionality.

If you made it this far, thank you for taking the time to acknowledge my issue. I’m not sure where else to go/try since I followed the same process as my previous functioning installation, only the previous used cmake to build and I’m now attempting to use VS2017 (building on windows this time)


#2

Could you make sure the version of CMake? I doubt that CMake version is too low. You could upgrade CMake to the latest.

If it doesn’t work, others you could try is removing cmake_build_type and so on.