Import topi error: libtvm_topi.so: undefined symbol: _ZTIN3tvm4NodeE


#1

I want to re-implement the benchmark given by the github repo: tvm-cuda-int8-benchmark. There is no problem building the shared library and installing tvm python package. But when I try to run python3 run_tvm.py, error occurs with message “libtvm_topi.so: undefined symbol: _ZTIN3tvm4NodeE” when trying to import topi.

@ vinx13 Do you have any idea about this?

I found a similar issue from another user: Import tvm error: libtvm.so: undefined symbol: _ZTIN3tvm4NodeE. While I can import tvm successfully, but cannot import topi.

My dev environment is:
Ubuntu 16.04 in a docker,
tvm @ e22b58
gcc 5.4.0 and cmake 3.5.1
a prebuilt binary LLVM of version 8.0 download from LLVM release page

By the way, I tried to use the docker image provided by TVM. But I found that its version is 0.4.0, which is older than the latest release(whichi is 0.5.0). I cannot run the benchmark script in the image. Will TVM release a newer image? After all, docker image is easy to deploy for quickly verifying some conclusion.


#2

OK, I solved the problem finally. I forgot to update HalideIR.