Unknown error when I'm running the first example


#1

I‘m a new learner of TVM. And I have built the environment with LLVM on Windows.
I’m going to run the first example relay_quick_start without revising anywhere.But there is an issue that I’m not understanding.I had searched many ways but can’t be solved.

Here are the details:

Traceback (most recent call last):
File “C:/Users/Administrator/Downloads/relay_quick_start.py”, line 43, in
from tvm import relay
File “C:\Users\Administrator\AppData\Roaming\Python\Python37\site-packages\tvm-0.6.dev0-py3.7-win-amd64.egg\tvm_init_.py”, line 23, in
from . import tensor
File “C:\Users\Administrator\AppData\Roaming\Python\Python37\site-packages\tvm-0.6.dev0-py3.7-win-amd64.egg\tvm\tensor.py”, line 20, in
from ._ffi.node import NodeBase, NodeGeneric, register_node, convert_to_node
File “C:\Users\Administrator\AppData\Roaming\Python\Python37\site-packages\tvm-0.6.dev0-py3.7-win-amd64.egg\tvm_ffi\node.py”, line 24, in
from .node_generic import NodeGeneric, convert_to_node, const
File “C:\Users\Administrator\AppData\Roaming\Python\Python37\site-packages\tvm-0.6.dev0-py3.7-win-amd64.egg\tvm_ffi\node_generic.py”, line 23, in
from .base import string_types
File “C:\Users\Administrator\AppData\Roaming\Python\Python37\site-packages\tvm-0.6.dev0-py3.7-win-amd64.egg\tvm_ffi\base.py”, line 60, in
_LIB, _LIB_NAME = _load_lib()
File “C:\Users\Administrator\AppData\Roaming\Python\Python37\site-packages\tvm-0.6.dev0-py3.7-win-amd64.egg\tvm_ffi\base.py”, line 52, in load_lib
lib = ctypes.CDLL(lib_path[0], ctypes.RTLD_GLOBAL)
File "C:\Program Files\Python37\lib\ctypes_init
.py", line 356, in init
self._handle = _dlopen(self._name, mode)
OSError: [WinError 126] 找不到指定的模块。

Is there anyone who can fix this problem? please tell me how to make it.
Thank you!


#2

Did you find the fix to this problem?


#3

sorry I haven’t found.


#4

Hi @lalaal, I figured the problem to this solution.

tvm.dll is dependent on a lot of other dlls based on your build.

In my case, they are -

The trick is to add the paths to the directory locations of where these DLLs exist in your system to the PATH variable!

In my case, I missed the path of SPIRV-tools-shared.dll. Adding the path to the bin folder of SPIRV solved my problem.