What is minimal python3 version requirements

Hi, my TVM env works fine under python3.5.2 until I pull new code ( fall behind couple of weeks).
There are syntax errors because of f-strings in 3.6.

However, I found no doc mentions Py3 version requirements. And now I have to update my python to 3.6 to use new tvm code.

Do TVM have specific py3 version requirements?
Or how can newest code in 2019.11 run on my old env (py 3.5)?

In fact, our docs says our minimal requirement is 3.5 (https://github.com/dmlc/tvm/issues/2715 ) But if you want to run correctly, you need at least 3.6 now as you said. We need to clarify this problem. To drop new syntax to meet 3.5 or require 3.6 @tqchen

From a forward looking point of view, perhaps we could update the docs to use 3.6

Let us open a RFC to see how people feels about that. [DISCUSS] Require python3.6 vs python 3.5 compatibility

In the meanwhile, we welcome PR to fix some of the f-string usages to keep 3.5 compatibility.

hi , could u show your which commit number us u r using

have submit a pr for the issue https://github.com/dmlc/tvm/pull/4250

https://docs.tvm.ai/contribute/code_guide.html#python-code-styles. I will point out that our coding guidelines require language features as in python 3.5.


1 Like

there’s also a typing.Deque issue in the code for py35, I tried a fix